
Google Docs – A Tutorial 
 

What is it? 

Google Docs is a free online program that allows users to create 

documents, spreadsheets and presentations online and share them with 

others for collaboration. This allows educators and students to share their 

work with others, collaborate on assignments, and save documents online 

for access at school or at home. 

 

Why use it? 

You can use Google Docs to: 

• Work on files anywhere, anytime 

• Get quick feedback from multiple people – simultaneously and asynchronously  

• Make the full writing process visible – including revisions 

• Quickly analyze and organize data 

• Easily share data sets 

• Publish documents for invitation viewing and editing or full public viewing 

• Upload and download documents in various file formats 

 

For a terrific introduction to Google Docs, check out “Google Docs in Plain English” – a production of the 

Common Craft Show.  http://snipurl.com/1vrzr  

 

 

http://www.youtube.com/watch?v=eRqUE6IHTEA
http://snipurl.com/1vrzr


Creating a Google Docs Account 

 

In order to use Google Docs you will need to register for a Google account. If you already have one through 

Gmail then you can use the same login to access Google Docs. If you do not have a Gmail account you may 

want to consider signing up for one so you can also use the Gmail and Calendar feature within Google. 

Otherwise you can just sign up for a Google account with an email address of your choice and a password. 

(This type of account does not provide the use of Gmail.)  

 

Note that while it's possible to view a document, spreadsheet or presentation without a Google Account 

(via an invitation), you'll need to create a Google Account to edit the document, spreadsheet or 

presentation, and to continue accessing Google Docs. 

 

1. Visit http://docs.google.com.  (Tip: You can also type Docs into your web browser) 

2. Optional: Click “Take a tour of Google Docs” to learn more about the features of this free Google 

Application. 

 

 

3. Sign into Google Docs:  

a. If you already have a Google account (i.e. you use another Google service, such as: Gmail, 

Google Calendar, iGoogle, Google Reader, Google Notebook, etc.) sign into Google Docs using 

your existing Google account.   

b. If not, click Get Started to create your Google account. 

http://docs.google.com/


c. New users can use any e-mail address to create a Google account, though they will have to 

confirm the creation of their new Google account in order to access all the features. 

i. Fill in all of the required form fields to 

sign up for the account, read through 

the Terms of Service, and click on I 

Accept. Create My Account. 

ii. You will need to verify your email 

address you used to create the 

account by signing into it and clicking 

on the link that Google Docs sends 

you.  

 

 

 

 

 

 



Creating and Working with a New Document 

 

Now that you have created a Google account and are able to access Google Docs you can begin 

creating or adding documents to your account. 

 

Part 1: Creating a New Document 

 

1. Click on New on the Menu bar and select which type of file you would like to create. For the 

purposes of this tutorial we will be using the Document option.  

 
 

2. Google Docs will open a new window that will allow you to create a word processed document.  

 
 



Part 2: Saving and Renaming a New Document  

 

3. In order to save your document you just need to click on the Save button. (You can also use the 

Save and Close button if you are finished working with the document.)  

 
4. You can also chose File on the Menu bar and then Save. In either case it will save the file using 

the text at the top of the document as the file name.  

 



5. If you would like to rename your file you can go to File on the Menu bar and choose Rename.  

 
6. Type in the new document name and click OK.  

 



Part 3: Uploading a Document  

 

1. In order to upload an existing document you just need to click on the Upload button on the Menu 

bar.  

 
2. Then you will need to click on the Browse button and find the document that you would like to 

upload.  

 
3. The path to your document will appear in the form field next to the Browse button. If the file is 

not on your computer but can be accessed via the web you can also type in the URL in the second 

form field. The third form field allows you to change the name before uploading. When you have 

completed these steps you will click on the Upload File button.  

 
4. Your file should now appear in your main window.  



Working with your Documents  

 

Just like in Microsoft Word you can copy, paste, bold, underline, italicize, and many other editing options. 

Although your editing options are not as comprehensive as a paid for program such as MS Word, you should 

find most of what you will need to create and edit your documents. This lesson will take you through some 

of the features that are available.  

 

Part 1: Edit Menu  

 

1. The Edit menu has many different options available. Most of the icons that are used should look familiar 

to you. For example the scissors icon represents the Cut feature and the clipboard icon represents the 

Paste feature. Take some time to familiarize yourself with the different options that are available.  

 
 

Part 2: Insert Menu  

 

2. The Insert menu also provides you with some options of inserting many types of objects such as images, 

links, comments, and tables. Take some time to familiarize yourself with these different options.  

 
 

Part 3: Spell Check  

 

3. Google Docs does have a Spell Check feature. It is located at the bottom right hand corner of your 

document. Click on the Check Spelling link and it will highlight the words it considers spelled 

incorrectly.  

 



 
4. If you click on the word a menu will pop up with suggestions on the correct spelling of the word. Choose 

which is correct to make the change or type in a change on your own. 

 
 



Part 4: Creating Folders to Organize Documents  

 

5. On your computer you probably have some sort of organization to storing your documents. This usually 

involves folders and sub folders. In Google Docs you have the same option for organizing your files. To 

create a new folder simply click on New on the Menu bar and choose Folder.  

 
6. Your screen will change to show you the new folder. You can change the name by clicking on the words 

New Folder in the middle window. It will highlight the words and make them editable. Type in the new 

name.  

 
7. You can also click on the Add Description/Status link just below the New Folder name and add a quick 

description of what is stored in that folder.  

 



8. This is what it will look like after you have added a new name and description.  

 
9. To place a document into a folder you will need to click on All Items in the left navigation menu to see 

all of your documents. Then choose the document you would like to move to a folder by checking the 

box next to it. Go to the Add to Folder button on the Menu bar and choose which folder you would like 

to add it to. You can do this for all your documents until you have them organized to your liking.  

 
10. In the left navigation menu you will now see your folders listed and how many items are in each of the 

folders.  

 



Sharing, Collaborating, and Publishing a Document  

 

A wonderful feature of Google Docs is the ability to share your work with others. You have many options to 

do this. You can give access to a document where the viewers are only able to read the document and not 

make any changes. You can also give access to a document where people can collaborate with you by 

making changes. You will be able to see the changes that each person has made to your document. In this 

lesson you will learn how to share your document with others and publish the final version. 

 

Note: In order to collaborate on a document the person you share the document with must have a Google 

Account. Otherwise they can only view the document. 

 

Part 1: Sharing and Collaborating on a Document  

 

1. Click on All Items in your left navigation menu to show all the items that you have in your Google Docs 

account. Select which one you would like to share with another person by clicking the checkbox in front 

of the document. Then click on the More Actions button on the Menu bar and select Share.  

 
2. You have the option to invite others to be Collaborators or Viewers. Collaborators are able to view as 

well as edit any documents that you share using this option. Viewers are only able to view the 

document. They are not able to make any changes to the document. After selecting the Collaborator or 

Viewer option you will need to type in the email addresses of the people with whom you would like to 

share the document. Separate addresses with a comma. Then click on the Invite Collaborators/Viewers 

button.  

 

Please note: If you'd like to allow Collaborators to add and delete other collaborators and/or viewers, 

select the checkbox next to Collaborators may invite others under Advanced permissions. Collaborators, 

once given this permission, can share the document by forwarding their invitation to others.   

 



To successfully add a mailing list, you must select the Invitations may be used by others checkbox (under 

Advanced permissions at the bottom of the screen). This allows all members of a group to access the 

document using this one invitation.  

 
3. A window will pop up that will ask you to type in a message that will be emailed along with the 

invitation to access the document. Type in your message and click on the Send button. You have the 

option to CC yourself on the message by making sure the checkbox is selected next to CC me.  

 
4. Anyone that receives the invitation can then click on the link within the message to begin viewing 

and/or editing the document. They will need to log in with their Google Account in order to edit if they 

are a collaborator.  

 



Limits for sharing:  

• For documents and presentations: 200 combined viewers and collaborators. 10 people may edit 

and/or view at any given time.  

• Spreadsheets: There is currently no limit to the number of people with whom you can share a 

spreadsheet. However, only 50 people can edit a spreadsheet at the same time.  

 

Part 3: Publishing a Document  

 

Publishing a document means that you will be making it available to anyone via the Internet. Google adds 

your document to the Google Index so that if someone does a search on the topic of your document it may 

be accessed.  

 

5. To publish your document you need to click on the Publish tab on the upper right side of your screen 

after selecting which document you would like to publish. A screen like the one below will appear.  

 
6. The Publishing tab allows you to publish to the Internet and will provide you with a URL. Or you can 

publish to your blog. You will need to set up your blog by clicking on the set up your blog site settings 

link. Choose which option by clicking on the Publish Document button or Post to Blog button. When 

choosing Publish Document a screen like the one below should appear. You can use the URL provided to 

share the document with others.  

 
 



Printing and Copying a Document  

 

Once you have a final version of your document you may want to print it. Or perhaps you want to have a 

copy of the original document before others start collaborating on it. (Which you can also achieve through 

the revisions tab) This lesson will show you how to print your document and make a copy of it.  

 

Part 1: Printing a Document  

 

1. To print the document open it and choose the Print link on the right hand upper corner between Preview 

and Email.  

 
2. Another option is to click on the File button on the Menu bar and choose Print.  

 



3. If your document prints with the URL of the webpage and other unnecessary information follow the 

instructions below to fix this issue.  

 

Note: Do not use the Print option in your browser's File menu. This will print the entire web page and not 

just your document. 

 

In Firefox for PC:  

1. Choose File > Page Setup. 

2. Select the Margins & Header/Footer tab. 

3. Set the headers and footers at the bottom of the window to Blank. 

4. Click OK. 

In Internet Explorer: 

1. Choose File > Page Setup. 

2. Delete the info that you see in the Header and Footer fields. 

3. Click OK. 

 

Part 2: Copying a Document  

 

4. To copy a document you will need to open the document and then choose File on the Menu bar and 

Copy.  

 



5. A confirmation message will pop up. Click OK to continue.  

 
6. The file should now be saved as "Copy of <Filename>" 

 
 

 

 

Tutorial adapted from the following resources (Note: URLs have been shortened at http://snipurl.com for 

convenience): 

• http://snipurl.com/1vrz9  

• http://snipurl.com/1vrza  

• http://snipurl.com/1vrzb 

• http://snipurl.com/1vrzc  

• http://snipurl.com/1vrzg 

• http://snipurl.com/1vrzh 

• http://snipurl.com/1vrzi  

 

Additional Resources: 

 

Using Google Docs in the Classroom 

• http://www.google.com/educators/learning_materials/WR_cribsheet.pdf  

• http://www.google.com/educators/learning_materials/WR_revisingguide.pdf  

• http://www.google.com/educators/activities/pdfs_GTA/CribSheet.Docs3.pdf  

• http://www.google.com/librariancenter/articles/0703_01.html 

http://www.google.com/educators/activities.html 

http://www.google.com/educators/weeklyreader.html 

 

Programs similar to Google Docs 

• http://www.zoho.com/ 

• http://thinkfree.com/  

 

 

Visit http://jdorman.wikispaces.com/Google for more Google resources 
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http://www.google.com/educators/activities/pdfs_GTA/CribSheet.Docs3.pdf
http://www.google.com/librariancenter/articles/0703_01.html
http://www.google.com/educators/activities.html
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